setup.py
changeset 46136 3158522085f0
parent 46046 f105c49e89cd
child 46233 172b294b6d65
--- a/setup.py	Mon Dec 14 14:59:23 2020 +0100
+++ b/setup.py	Mon Dec 14 17:59:10 2020 -0500
@@ -1309,6 +1309,13 @@
     'hgdemandimport',
 ]
 
+# The pygit2 dependency dropped py2 support with the 1.0 release in Dec 2019.
+# Prior releases do not build at all on Windows, because Visual Studio 2008
+# doesn't understand C 11.  Older Linux releases are buggy.
+if sys.version_info[0] == 2:
+    packages.remove('hgext.git')
+
+
 for name in os.listdir(os.path.join('mercurial', 'templates')):
     if name != '__pycache__' and os.path.isdir(
         os.path.join('mercurial', 'templates', name)