rust/hg-core/Cargo.toml
changeset 45526 26c53ee51c68
parent 44935 2093b2fc70d4
child 45531 b0d6309ff50c
--- a/rust/hg-core/Cargo.toml	Wed Sep 16 18:09:32 2020 +0530
+++ b/rust/hg-core/Cargo.toml	Fri Sep 04 11:55:07 2020 +0200
@@ -23,9 +23,19 @@
 crossbeam = "0.7.3"
 micro-timer = "0.3.0"
 log = "0.4.8"
+memmap = "0.7.0"
+zstd = "0.5.3"
+
+# We don't use the `miniz-oxide` backend because its minimum Rust version is
+# `1.36`. However, this PR (https://github.com/Frommi/miniz_oxide/pull/84/files)
+# introduces a flag `no_extern_crate_alloc` to bring the requirement back down
+# to `1.34`.
+[dependencies.flate2]
+version = "1.0.16"
+features = ["zlib"]
+default-features = false
 
 [dev-dependencies]
 clap = "*"
-memmap = "0.7.0"
 pretty_assertions = "0.6.1"
 tempfile = "3.1.0"