setup.py
changeset 39986 138e2d6d3b53
parent 39772 ae531f5e583c
child 40121 73fef626dae3
--- a/setup.py	Tue Oct 02 09:11:18 2018 -0700
+++ b/setup.py	Tue Oct 02 22:40:01 2018 -0400
@@ -262,7 +262,9 @@
                and not e.startswith(b'warning: Not importing')
                and not e.startswith(b'obsolete feature not enabled')
                and not e.startswith(b'*** failed to import extension')
-               and not e.startswith(b'devel-warn:'))]
+               and not e.startswith(b'devel-warn:')
+               and not (e.startswith(b'(third party extension')
+                        and e.endswith(b'or newer of Mercurial; disabling)')))]
     return b'\n'.join(b'  ' + e for e in err)
 
 def findhg():