setup.py
changeset 48837 12cba4886e90
parent 48836 e020dbbc41e5
child 48838 cd3e25adcf84
--- a/setup.py	Wed Mar 02 10:25:11 2022 -0500
+++ b/setup.py	Wed Mar 02 10:29:54 2022 -0500
@@ -1380,13 +1380,9 @@
 
         cargocmd = ['cargo', 'rustc', '--release']
 
-        feature_flags = []
+        feature_flags = ['python3']
 
         cargocmd.append('--no-default-features')
-        if sys.version_info[0] == 2:
-            feature_flags.append('python27')
-        elif sys.version_info[0] == 3:
-            feature_flags.append('python3')
 
         rust_features = env.get("HG_RUST_FEATURES")
         if rust_features: