rust/hg-core/Cargo.toml
changeset 49005 12adf8c695ed
parent 48953 ec8d9b5a5e7c
parent 49000 dd6b67d5c256
child 49279 127d33e63d1a
--- a/rust/hg-core/Cargo.toml	Wed Mar 30 00:57:08 2022 -0400
+++ b/rust/hg-core/Cargo.toml	Tue Apr 05 11:09:03 2022 +0200
@@ -18,8 +18,9 @@
 im-rc = "15.0.0"
 itertools = "0.10.3"
 lazy_static = "1.4.0"
-libc = "0.2.119"
-rand = "0.8.5"
+libc = "0.2"
+ouroboros = "0.15.0"
+rand = "0.8.4"
 rand_pcg = "0.3.1"
 rand_distr = "0.4.3"
 rayon = "1.5.1"
@@ -27,12 +28,11 @@
 sha-1 = "0.10.0"
 twox-hash = "1.6.2"
 same-file = "1.0.6"
-stable_deref_trait = "1.2.0"
-tempfile = "3.3.0"
-crossbeam-channel = "0.5.2"
-micro-timer = "0.4.0"
-log = "0.4.14"
-memmap2 = { version = "0.5.3", features = ["stable_deref_trait"] }
+tempfile = "3.1.0"
+crossbeam-channel = "0.4"
+micro-timer = "0.3.0"
+log = "0.4.8"
+memmap2 = {version = "0.4", features = ["stable_deref_trait"]}
 zstd = "0.5.3"
 format-bytes = "0.3.0"