setup.py
changeset 7648 02e358a3a8a7
parent 7647 f7256cd9beff
child 7649 a489e3a94443
--- a/setup.py	Thu Jan 15 11:41:59 2009 +0100
+++ b/setup.py	Thu Jan 15 00:10:54 2009 +0100
@@ -149,6 +149,12 @@
 except ImportError:
     pass
 
+datafiles = []
+for root in ('templates', 'i18n'):
+    for dir, dirs, files in os.walk(root):
+        datafiles.append((os.path.join('mercurial', dir),
+                          [os.path.join(dir, file_) for file_ in files]))
+
 setup(name='mercurial',
       version=version,
       author='Matt Mackall',
@@ -159,9 +165,7 @@
       scripts=scripts,
       packages=packages,
       ext_modules=ext_modules,
-      data_files=[(os.path.join('mercurial', root),
-                   [os.path.join(root, file_) for file_ in files])
-                  for root, dirs, files in os.walk('templates')],
+      data_files=datafiles,
       cmdclass=cmdclass,
       options=dict(py2exe=dict(packages=['hgext', 'email']),
                    bdist_mpkg=dict(zipdist=True,