contrib/packaging/mercurial.spec
changeset 45836 de1f4c431619
parent 43358 518655314fc5
child 45935 eccbfa7e19c0
equal deleted inserted replaced
45835:f38d592f871a 45836:de1f4c431619
     1 %global emacs_lispdir %{_datadir}/emacs/site-lisp
     1 %global emacs_lispdir %{_datadir}/emacs/site-lisp
     2 
     2 
     3 %define withpython %{nil}
     3 %define withpython %{nil}
     4 
     4 
     5 %global pythonexe python3
     5 %global pythonexe python3
       
     6 %global pythondocutils python3-docutils
     6 
     7 
     7 %if "%{?withpython}"
     8 %if "%{?withpython}"
     8 
     9 
     9 %global pythonver %{withpython}
    10 %global pythonver %{withpython}
    10 %global pythonname Python-%{withpython}
    11 %global pythonname Python-%{withpython}
    37 
    38 
    38 BuildRequires: make, gcc, gettext
    39 BuildRequires: make, gcc, gettext
    39 %if "%{?withpython}"
    40 %if "%{?withpython}"
    40 BuildRequires: readline-devel, openssl-devel, ncurses-devel, zlib-devel, bzip2-devel
    41 BuildRequires: readline-devel, openssl-devel, ncurses-devel, zlib-devel, bzip2-devel
    41 %else
    42 %else
    42 BuildRequires: %{pythonexe} >= %{pythonver}, %{pythonexe}-devel, %{pythonexe}-docutils >= 0.5
    43 BuildRequires: %{pythonexe} >= %{pythonver}, %{pythonexe}-devel, %{pythondocutils}
    43 Requires: %{pythonexe} >= %{pythonver}
    44 Requires: %{pythonexe} >= %{pythonver}
    44 %endif
    45 %endif
    45 # The hgk extension uses the wish tcl interpreter, but we don't enforce it
    46 # The hgk extension uses the wish tcl interpreter, but we don't enforce it
    46 #Requires: tk
    47 #Requires: tk
    47 
    48