contrib/packaging/debian/rules
branchstable
changeset 43320 7b638d25b8e4
parent 43319 11c85873e106
child 45006 36178b5c9aeb
equal deleted inserted replaced
43319:11c85873e106 43320:7b638d25b8e4
    13 override_dh_auto_test:
    13 override_dh_auto_test:
    14 	http_proxy='' dh_auto_test -- TESTFLAGS="-j$(CPUS)"
    14 	http_proxy='' dh_auto_test -- TESTFLAGS="-j$(CPUS)"
    15 
    15 
    16 override_dh_python3:
    16 override_dh_python3:
    17 	dh_python3 --shebang=/usr/bin/python3
    17 	dh_python3 --shebang=/usr/bin/python3
    18 	find debian/mercurial/usr/share -type d -empty -delete
       
    19 
    18 
    20 override_dh_auto_clean:
    19 override_dh_auto_clean:
    21 	$(MAKE) cleanbutpackages
    20 	$(MAKE) cleanbutpackages
    22 	$(MAKE) -C contrib/chg clean
    21 	$(MAKE) -C contrib/chg clean
    23 
    22 
    30 	# chg
    29 	# chg
    31 	make -C contrib/chg \
    30 	make -C contrib/chg \
    32 		DESTDIR="$(CURDIR)"/debian/mercurial \
    31 		DESTDIR="$(CURDIR)"/debian/mercurial \
    33 		PREFIX=/usr \
    32 		PREFIX=/usr \
    34 		install
    33 		install
    35 	# remove arch-independent python stuff
    34 	make install-doc PREFIX="$(CURDIR)"/debian/mercurial/usr
    36 	find "$(CURDIR)"/debian/mercurial/usr/lib \
    35 	cp contrib/hg-ssh "$(CURDIR)"/debian/mercurial/usr/bin
    37 		! -name '*.so' ! -type d -delete , \
    36 	mkdir -p "$(CURDIR)"/debian/mercurial/usr/share/mercurial
    38 		-type d -empty -delete
    37 	cp contrib/hgk "$(CURDIR)"/debian/mercurial/usr/share/mercurial
    39 	python3 setup.py install --root "$(CURDIR)/debian/mercurial-common" --install-layout=deb
    38 	mkdir -p "$(CURDIR)"/debian/mercurial/etc/mercurial/hgrc.d/
    40 	make install-doc PREFIX="$(CURDIR)"/debian/mercurial-common/usr
    39 	cp contrib/packaging/debian/*.rc "$(CURDIR)"/debian/mercurial/etc/mercurial/hgrc.d/
    41 	# remove arch-dependent python stuff
       
    42 	find "$(CURDIR)"/debian/mercurial-common/usr/lib \
       
    43 		-name '*.so' ! -type d -delete , \
       
    44 		-type d -empty -delete
       
    45 	cp contrib/hg-ssh "$(CURDIR)"/debian/mercurial-common/usr/bin
       
    46 	mkdir -p "$(CURDIR)"/debian/mercurial-common/usr/share/mercurial
       
    47 	cp contrib/hgk "$(CURDIR)"/debian/mercurial-common/usr/share/mercurial
       
    48 	mkdir -p "$(CURDIR)"/debian/mercurial-common/etc/mercurial/hgrc.d/
       
    49 	cp contrib/packaging/debian/*.rc "$(CURDIR)"/debian/mercurial-common/etc/mercurial/hgrc.d/
       
    50 	# completions
    40 	# completions
    51 	mkdir -p "$(CURDIR)"/debian/mercurial-common/usr/share/bash-completion/completions
    41 	mkdir -p "$(CURDIR)"/debian/mercurial/usr/share/bash-completion/completions
    52 	cp contrib/bash_completion "$(CURDIR)"/debian/mercurial-common/usr/share/bash-completion/completions/hg
    42 	cp contrib/bash_completion "$(CURDIR)"/debian/mercurial/usr/share/bash-completion/completions/hg
    53 	mkdir -p "$(CURDIR)"/debian/mercurial-common/usr/share/zsh/vendor-completions
    43 	mkdir -p "$(CURDIR)"/debian/mercurial/usr/share/zsh/vendor-completions
    54 	cp contrib/zsh_completion "$(CURDIR)"/debian/mercurial-common/usr/share/zsh/vendor-completions/_hg
    44 	cp contrib/zsh_completion "$(CURDIR)"/debian/mercurial/usr/share/zsh/vendor-completions/_hg
    55 	rm "$(CURDIR)"/debian/mercurial-common/usr/bin/hg