mcabber/configure.ac
changeset 1668 41c26b7d2890
parent 1639 d9913c1b35e7
child 1670 efee21002ffb
--- a/mcabber/configure.ac	Tue Feb 02 21:27:26 2010 +0100
+++ b/mcabber/configure.ac	Mon Jan 18 15:36:19 2010 +0200
@@ -4,8 +4,9 @@
 AC_PREREQ(2.59)
 AC_INIT([mcabber],[0.10.0-dev],[mcabber@lilotux.net])
 AM_INIT_AUTOMAKE
-AC_CONFIG_SRCDIR([src])
-AM_CONFIG_HEADER(config.h)
+AC_CONFIG_SRCDIR([mcabber])
+AM_CONFIG_HEADER(mcabber/config.h)
+#AC_CONFIG_HEADER(include/config.h)
 
 #AC_PROG_LIBTOOL
 AC_PROG_RANLIB
@@ -253,11 +254,12 @@
 fi
 
 AM_CONDITIONAL([OTR], [test x$libotr_found = xyes])
+AM_CONDITIONAL([INSTALL_HEADERS], [test x$enable_modules = xyes])
 
 # We need _GNU_SOURCE for strptime() and strcasestr()
 CFLAGS="$CFLAGS -D_GNU_SOURCE"
 
-AC_CONFIG_FILES([src/Makefile
+AC_CONFIG_FILES([mcabber/Makefile
                  doc/Makefile
                  doc/guide/Makefile
                  doc/help/Makefile