configure.ac
changeset 2 b6516e8751bb
parent 1 99fd216641d8
child 4 807420cf8002
--- a/configure.ac	Sun Mar 07 14:51:10 2010 +0100
+++ b/configure.ac	Sun Mar 07 15:13:49 2010 +0100
@@ -68,8 +68,7 @@
                                   [g_list_append], ["$gmodule_module"])],
                  [g_regex_new "$gmodule_module"])
 
-# Export $libexecdir to the source tree
-AC_DEFINE_DIR(PKGLIB_DIR, "${libdir}/${PACKAGE}", [Modules directory])
+PKG_CHECK_MODULES(MCABBER, mcabber >= 0.10.0)
 
 AC_ARG_ENABLE(debug,
     [AC_HELP_STRING(--enable-debug, add development compilation options)],
@@ -92,6 +91,11 @@
 # We need _GNU_SOURCE for strptime() and strcasestr()
 CFLAGS="$CFLAGS -D_GNU_SOURCE"
 
+AC_ARG_ENABLE(all-modules, [  --enable-all-modules    enable all modules],
+              enable_all_modules=$enableval)
+
+AM_CONDITIONAL([INSTALL_HEADERS], [test x$enable_all_modules = xyes])
+
 AC_CONFIG_FILES([comment/Makefile
                  extsay/Makefile
                  Makefile])