configure.ac
changeset 19 85296f26810e
parent 17 be7e71438f76
child 21 9798e3aaa851
--- a/configure.ac	Mon Mar 29 00:46:24 2010 +0200
+++ b/configure.ac	Wed Mar 31 22:58:04 2010 +0200
@@ -110,6 +110,10 @@
               AC_HELP_STRING([--enable-module-info_msgcount],
                              [enable module info_msgcount]),
               enable_module_info_msgcount=$enableval)
+AC_ARG_ENABLE(module-killpresence,
+              AC_HELP_STRING([--enable-module-killpresence],
+                             [enable module killpresence]),
+              enable_module_lastmsg=$enableval)
 AC_ARG_ENABLE(module-lastmsg,
               AC_HELP_STRING([--enable-module-lastmsg], [enable module lastmsg]),
               enable_module_lastmsg=$enableval)
@@ -130,6 +134,10 @@
                [test x"${enable_all_modules}" = x"yes" -o \
                      x"${enable_module_info_msgcount}" = x"yes"])
 
+AM_CONDITIONAL([INSTALL_MODULE_KILLPRESENCE],
+               [test x"${enable_all_modules}" = x"yes" -o \
+                     x"${enable_module_killpresence}" = x"yes"])
+
 AM_CONDITIONAL([INSTALL_MODULE_LASTMSG],
                [test x"${enable_all_modules}" = x"yes" -o \
                      x"${enable_module_lastmsg}" = x"yes"])
@@ -138,6 +146,7 @@
                  comment/Makefile
                  extsay/Makefile
                  info_msgcount/Makefile
+                 killpresence/Makefile
                  lastmsg/Makefile
                  Makefile])
 AC_OUTPUT