configure.ac
changeset 38 3dad6bd6cde2
parent 34 105fdf20c1c1
child 48 06495be653fd
--- a/configure.ac	Sun Apr 11 15:27:59 2010 +0200
+++ b/configure.ac	Sat Nov 06 20:50:52 2010 +0100
@@ -109,6 +109,10 @@
               AC_HELP_STRING([--enable-module-extsayng],
                              [enable module extsayng]),
               enable_module_extsayng=$enableval)
+AC_ARG_ENABLE(module-ignore_auth,
+              AC_HELP_STRING([--enable-module-ignore_auth],
+                             [enable module ignore_auth]),
+              enable_module_ignore_auth=$enableval)
 AC_ARG_ENABLE(module-info_msgcount,
               AC_HELP_STRING([--enable-module-info_msgcount],
                              [enable module info_msgcount]),
@@ -134,6 +138,10 @@
                [test x"${enable_all_modules}" = x"yes" -o \
                      x"${enable_module_extsayng}" = x"yes"])
 
+AM_CONDITIONAL([INSTALL_MODULE_IGNORE_AUTH],
+               [test x"${enable_all_modules}" = x"yes" -o \
+                     x"${enable_module_ignore_auth}" = x"yes"])
+
 AM_CONDITIONAL([INSTALL_MODULE_INFO_MSGCOUNT],
                [test x"${enable_all_modules}" = x"yes" -o \
                      x"${enable_module_info_msgcount}" = x"yes"])
@@ -149,6 +157,7 @@
 AC_CONFIG_FILES([clock/Makefile
                  comment/Makefile
                  extsay-ng/Makefile
+                 ignore_auth/Makefile
                  info_msgcount/Makefile
                  killpresence/Makefile
                  lastmsg/Makefile