mcabber/configure.ac
changeset 2086 3667697d677d
parent 2084 e3325bad2e0c
child 2089 91a8f3740a1a
--- a/mcabber/configure.ac	Thu Oct 24 22:52:01 2013 +0200
+++ b/mcabber/configure.ac	Fri Oct 25 21:27:31 2013 +0200
@@ -154,6 +154,13 @@
 # Check for loudmouth
 PKG_CHECK_MODULES(LOUDMOUTH, loudmouth-1.0 >= 1.4.2)
 
+# Check for lm_ssl_set_cipher_list in loudmouth
+AC_CHECK_LIB(loudmouth-1, lm_ssl_set_cipher_list,
+              AC_DEFINE([HAVE_LM_SSL_CIPHER_LIST], 1,
+                        [Define that loudmouth has lm_ssl_cipher_list]
+                        )
+            )
+
 # Check for libidn
 AC_ARG_WITH(libidn, AC_HELP_STRING([--with-libidn=[DIR]],
                                    [Support IDN (needs GNU Libidn)]),