CMakeLists.txt
changeset 66 a40beb82130c
parent 65 72ffcf688664
--- a/CMakeLists.txt	Sat Mar 05 18:04:48 2016 +0200
+++ b/CMakeLists.txt	Wed Mar 16 01:53:56 2016 +0200
@@ -16,7 +16,7 @@
 
 cmake_minimum_required(VERSION 2.6)
 project(lua-lm C)
-set(PROJECT_VERSION "0.9.6")
+set(PROJECT_VERSION "0.9.7")
 
 ## User options
 option(DEBUG         "Enable debugging output" OFF)
@@ -55,6 +55,7 @@
 	pkg_check_modules(LM REQUIRED loudmouth-1.0)
 endif()
 include(CheckFunctionExists)
+include(CheckStructHasMember)
 set(CMAKE_REQUIRED_INCLUDES ${LM_INCLUDE_DIRS})
 set(CMAKE_REQUIRED_LIBRARIES ${LM_LIBRARIES})
 set(CMAKE_REQUIRED_FLAGS ${LM_LDFLAGS} ${LM_CFLAGS})
@@ -62,6 +63,7 @@
 check_function_exists(lm_connection_unregister_reply_handler HAVE_LM_CONNECTION_UNREGISTER_REPLY_HANDLER)
 check_function_exists(lm_ssl_set_ca HAVE_LM_SSL_SET_CA)
 check_function_exists(lm_ssl_set_cipher_list HAVE_LM_SSL_SET_CIPHER_LIST)
+check_struct_has_member("LmMessageNodeAttribute" next loudmouth/loudmouth.h HAVE_LM_MESSAGE_NODE_ATTRIBUTE)
 find_program(DOCGEN_EXECUTABLE NAMES docgen.pl docgen DOC "Docgen documentation generator script (optional)")
 # (this should be before targets definitions)
 link_directories(${LUA_LIBRARY_DIRS} ${GLIB_LIBRARY_DIRS} ${LM_LIBRARY_DIRS})