CMakeLists.txt
changeset 59 19cfaceda6bb
parent 57 37ed3c7ac1b6
child 62 d92358eafead
--- a/CMakeLists.txt	Sat Mar 05 14:57:58 2016 +0200
+++ b/CMakeLists.txt	Sat Mar 05 15:43:04 2016 +0200
@@ -1,4 +1,4 @@
-## Copyright 2009,2011 Myhailo Danylenko
+## Copyright 2009-2016 Myhailo Danylenko
 # This file is part of lua-lm
 #
 # lua-lm is free software: you can redistribute it and/or modify
@@ -16,7 +16,7 @@
 
 cmake_minimum_required(VERSION 2.6)
 project(lua-lm C)
-set(PROJECT_VERSION "0.9.3")
+set(PROJECT_VERSION "0.9.4")
 
 ## User options
 option(DEBUG      "Enable debugging output" OFF)
@@ -57,6 +57,8 @@
 set(CMAKE_REQUIRED_FLAGS ${LM_LDFLAGS} ${LM_CFLAGS})
 check_function_exists(lm_connection_get_keep_alive_rate HAVE_LM_CONNECTION_GET_KEEP_ALIVE_RATE)
 check_function_exists(lm_connection_unregister_reply_handler HAVE_LM_CONNECTION_UNREGISTER_REPLY_HANDLER)
+check_function_exists(lm_ssl_set_ca HAVE_LM_SSL_SET_CA)
+check_function_exists(lm_ssl_set_cipher_list HAVE_LM_SSL_SET_CIPHER_LIST)
 find_program(DOCGEN_EXECUTABLE NAMES docgen.pl docgen DOC "Docgen documentation generator script (optional)")
 # (this should be before targets definitions)
 link_directories(${LUA_LIBRARY_DIRS} ${GLIB_LIBRARY_DIRS} ${LM_LIBRARY_DIRS})